SolinSystem | 솔인시스템 - resin

서비스  |  기술지원 게시판 글보기



[답변]레진과 postgrsql jdbc 설정 오류 질문드립니다.
관리자 / / 2019-02-08 16:30



Content 


안녕하세요. 솔인시스템 기술지원팀 입니다.

일반적으로 java.lang.UnsupportedClassVersionError: Bad version number in .class file 에러는 어플리케이션 class 파일을 컴파일 할 때 사용했던 jdk 버전이 Resin에서 설정된 jdk 버전보다 상위일 때 호환이 되지 않아 발생하는 에러입니다.

Resin 라이브러리에 있는 jdbc connector 파일을 Resin에 설정된 jdk 1.5 버전과 호환되는 파일로 변경해보시고 다시 기동해보시기 바랍니다.

감사합니다.